[Xcode] Error: xcode-select: error: tool ‘xcodebuild’ requires Xcode

error

以下のエラーが出ました。

あれ〜?おかしいなー昨日までビルドできてたのになー。

原因

原因は、Xcode の更新の際に古いバージョンも一応とっておきたくて
以下のディレクトリ構成にしたからでした。

はい。ばかでしたね。
というわけで、それまで通り Application 直下に .app を設置したらエラーはなくなりました。

めでたしめでたし

etc

上記は私の稀有なケースですが、
そうではなくてエラーが出てしまった方は、以下で直るかも

ちなみにさっきの “Xcode_8_3” というディレクトリ作ってしまったときも
この “--switch” で設定すればそれはそれで解決ですね。
 


<広告>


コメントを残す

メールアドレスが公開されることはありません。